Обновление с 2.9.4 до 3.0.x и с настраиваемой темой

У меня есть сайт, где тема ОЧЕНЬ такова, и я больше не могу работать с разработчиком.

Должен ли я беспокоиться о том, что тема больше не работает в версии 3.0.4. и если да, то какой самый простой способ проверить мою тему перед обновлением?

благодаря

Эрик

Solutions Collecting From Web of "Обновление с 2.9.4 до 3.0.x и с настраиваемой темой"

Попробуйте эти простые шаги, чтобы проверить это!

  1. Установите WP DB-Backup в версию 2.9.4.
  2. Резервное копирование DB
  3. Настройка тестового сервера с помощью WordPress 3.0.4
  4. Установка WP-DB-Резервное копирование и восстановление из предыдущей резервной копии
  5. Проверьте свою тему

Самый простой способ проверить – не беспокоиться о резервном копировании и восстановлении БД или о другом сервере. Установите 3.0.4 во вложенную папку, например / wordpress304 /, и используйте другой префикс базы данных, например wp304_, потому что вы используете тот же БД, что и первая установка. Проверьте тему. Если он работает, обновите первую установку до версии 3.0.4 и удалите установку подпапки и используемые в ней таблицы базы данных. Если это не сработает, у вас есть способ исправить код, прежде чем использовать его вживую.