Отсутствие сообщений в списке пользовательских таксономии

Симптом: пользовательский тип сообщения, назначенный для таксономии, не отображается в таблице администратора, в котором перечислены все сообщения с определенным сроком присоединения.

Из моей панели инструментов, если я нажимаю на таксономию под настраиваемым типом сообщения, я получаю список терминов. Один термин показывал 3 сообщения, но когда я нажал на номер 3, итоговый список показывал только 2 сообщения. В качестве теста я создал новый пользовательский пост и назначил его на тот же срок. Теперь список терминов показывает, что этот термин содержит 4 сообщения. Однако, нажав на номер 4, я все же даю мне список из 2 сообщений. Я переместил сообщения на другие термины и получил тот же результат, а именно 2 сообщения по-прежнему отсутствуют.

Я не знаю, где искать анализ этой проблемы. Я подозреваю, что я либо делаю что-то очень глупое (я проверял очевидные вещи, как опубликованный пользовательский пост), или, возможно, что-то в моей базе данных повреждено.

Я не думаю, что есть полезный код, который я могу предоставить. Мне кажется, что проблема связана с постами. У меня есть рабочая версия этого на сайте разработки, которая отлично работает. Теперь я пытаюсь воссоздать ту же ситуацию на производственной площадке, и этот странный симптом появился.

Я был бы признателен за любые предложения по дополнительной информации, которые я мог бы предоставить здесь, или любые вероятные расследования, которые я могу сделать, чтобы найти источник проблемы.

Solutions Collecting From Web of "Отсутствие сообщений в списке пользовательских таксономии"

Я решил это, удалив таксономию и создав новую таксономию с немного другим именем. Первоначальные тесты показывают, что проблема была удалена, хотя я не могу сказать, что понимаю, что вызвало ее.
Перед удалением таксономии, вызвавшей проблему, я создал новую таксономию теста и показал, что она работает правильно. Я также сделал резервную копию сайта.