Intereting Posts
Как контролировать регистрацию пользователей непосредственно на подсайтах Архивный шаблон для персонализированного типа сообщений содержит только первые 10 Одна функция register_sidebar работает, а другая нет? Shortcode возвращает значения в неправильном порядке Получить название термина от идентификатора срока действия? Как отключить панель администратора для всех подписчиков? Изменение меток меню администратора Как мне отладить ошибку, которую вызывает плагин? В чем разница между перехватами update_post_meta и update_postmeta? Три столбца Ограничить доступ и отображение для категорий Не удалось найти корневую директорию WordPress Добавление div после каждых двух сообщений в основной петле! Почему первый пост не подсчитывается? Могу ли я помешать авторам изменить шрифт в своем сообщении? Роли, отличные от Super admin, доступ к manage_network_themes

Использование _e () в тексте внутри видеоэлементов печатает этот текст, а не только показывается, когда элемент html5 <video> не поддерживается

Я создаю тему WordPress, в которой я создаю короткий код для видео. Часть вывода этого короткого кода выглядит примерно так:

$result .= '<video class="fullWidth" width="auto" height="auto" loop muted preload>'; $result .= '<source src="'.$mp4.'" type="video/mp4" />'; $result .= '<source src="'.$webm.'" type="video/webm" />'; $result .= '<source src="'.$ogv.'" type="video/ogv" />'; $result .= _e('Video tag is not supported in your browser.', 'my-theme-framework'); $result .= '</video>'; 

Теперь видео работает, но текст «Vide tag is …» получает эхо, но когда я удаляю текст из функции, он скрывается. Поэтому я считаю, что это из-за функции _e (), и я не знаю, что делать. Мне нужно, чтобы сделать перевод текста готовым, следует ли его удалить?

Я искал для этого, но у меня нет соответствующих результатов. Скажите, пожалуйста, знаете ли вы, что я должен делать здесь.

Спасибо.

Solutions Collecting From Web of "Использование _e () в тексте внутри видеоэлементов печатает этот текст, а не только показывается, когда элемент html5 <video> не поддерживается"