Intereting Posts
Клонирование блога WordPress .. проблема с wp-admin Как добавить опцию «Шаблон» в панели атрибутов страницы? Скрыть мета-окно для всего, НО определенный пользовательский тип сообщения Добавление пользовательского каталога и файлов PHP в wordpress Не удается войти в WP после принудительного восстановления Существуют ли отдельные распределения памяти для разных пользовательских ролей в WordPress? Правильный способ отображения пользовательской таксономии для вложений изображений в файл шаблона Отправлять почту пользователю только один раз, когда выбран определенный флажок и обновлен из профиля, обновленного администратором Как изменить каталог временного обновления? Как сбросить обычный запрос $ на странице поиска, чтобы отправить пользовательский запрос $ wpdb? HTML, созданный WP Как изменить только часть функции через фильтр Отфильтровать запрос ТОЛЬКО для страницы результатов поиска Как получить доступ к переменной страницы внутри действия Доступ к переменной из панели администратора?

Расширенный загрузчик страницы AJAX игнорирует другой код JS

В настоящее время я работаю над сайтом WordPress для начинающей музыкальной студии.

На сайте пользователь имеет возможность прослушивать некоторые из исполнителей в встроенном музыкальном проигрывателе. Этот проигрыватель будет продолжать воспроизведение музыкальной дорожки, когда пользователь навигация по сайту. Чтобы сделать эту работу, сайт использует плагин под названием «Advanced AJAX Page Loader».

Но есть одна серьезная проблема с этим плагином; Он игнорирует все другие встроенные JavaScript на сайте. Я попробовал Google и прочитал FAQ на сайте WordPress плагинов. Все говорят одно и то же:

Поместите код привязки в файл JS после строки, в которой говорится: «УБЕДИТЕСЬ, ЧТОБЫ ПЕРЕЗАГРУЗИТЬ КОДЫ НИЖЕ ЗДЕСЬ»,

Но есть одна проблема с этим. Какой JS-файл? У меня есть 3 JS-файла в папке плагина, и ни одна из них не содержит предложение «УБЕДИТЕСЬ К ВАШИМ КОДАМ РЕЗЬБЫ НИЖЕ ЗДЕСЬ».

Еще недавно я обнаружил, что на плагине в WordPress постоянно говорится, что для этого плагина требуется обновление. (Версия 9.1). Но когда я пытаюсь его обновить, он говорит, что загрузка завершилась неудачно, потому что URL-адрес недействителен. Но когда я проверяю сайт WordPress плагинов, он говорит, что версия 2.7.7 (тот, который у меня есть) является текущей?

Так есть ли кто-нибудь, кто знает, исправить все это или, возможно, альтернативный или лучший плагин? Потому что сейчас плагин абсолютно бесполезен для меня.

благодаря

Solutions Collecting From Web of "Расширенный загрузчик страницы AJAX игнорирует другой код JS"