Intereting Posts

Плагин JQuery, который работает с Google 1.10.2, а не с WordPress 1.10.2

Я делаю пользовательскую реализацию JQuery Colorbox в плагине WordPress. Однако он не работает с моей установкой WordPress по умолчанию. Немного поразмыслив, это сводится к включению библиотеки JQuery.

Ни одна из этих строк не работает:

<script src='http://xpisobsolete.com/wp-includes/js/jquery/jquery.js?ver=1.10.2'></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

Но любой из них:

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

Я тестировал, что JQuery работает со всем вышеперечисленным, используя:

 if (typeof jQuery != 'undefined') { alert("jQuery library is loaded!"); }else{ alert("jQuery library is not found!"); } 

Он передает все четыре ссылки на скрипт, которые я пробовал. Если я изменю одну строку на демо-странице Джека, она тоже сломается. Это проблема с цветом? http://www.jacklmoore.com/colorbox/example1/

Не могли бы вы, ребята, помочь мне увидеть, что мне здесь не хватает? Я в тупике.

Solutions Collecting From Web of "Плагин JQuery, который работает с Google 1.10.2, а не с WordPress 1.10.2"

Попробуйте разместить свой код в этом

 (function($) { // Inside of this function, $() will work as an alias for jQuery() // and other libraries also using $ will not be accessible under this shortcut })(jQuery); 

Я подозреваю, что ваш код использует $ , что обычно является псевдонимом для jQuery но не работает во всем мире, потому что версия jQuery WP не находится в режиме конфликта. $ будет работать, если код помещается в корпус, такой как тот, который указан выше.