PGP-шифрование системных уведомлений

Мне было интересно, есть ли способ заставить WordPress шифровать сообщения электронной почты («Please умер …» и т. Д.), Используя PGP.

Я нашел кучу плагинов, предоставляющих PGP-зашифрованные формы электронной почты, но это не то, что я искал, так как я хочу, чтобы системные письма были зашифрованы, а не почтовые сообщения пользователей.

Есть ли какой-либо плагин или модификация, которая делает это, чего я не нашел?

Solutions Collecting From Web of "PGP-шифрование системных уведомлений"

Там есть небольшой плагин PGP от Тима Нэша на GitHub (но он не находится в официальном репозитории WordPress, его нужно скопировать вручную в каталог wordpress plugin). Это оболочка, использующая библиотеку php-pgp для шифрования. Статья, в которой я нашел эту ссылку, – «Шифрование писем с помощью PGP и WordPress» . Это единственное решение WordPress, которое я нашел до сих пор.

Я также копал в тему, и я пытаюсь использовать более общий подход – расширение PHPMailer для поддержки шифрования PGP. Однако для этого требуется некоторое тестирование для поддержки электронной почты в текстовом и html-формате, PGP / MIME, вложениях и т. Д., Так что это еще не готово к публикации.