Intereting Posts
Pull Youtube Ссылка со второго WP_Editor Использование get_template_part () возвращает параметры загрузки «недопустимый аргумент» Есть ли крючок, который запускается после входа пользователя в систему? Удаление поддержки Gravatar.com для WordPress и простых локальных аватаров Обновление профиля пользователя с помощью AJAX не работает Count foreach и отображение в меню php Удалить изображения, загруженные ролью «Подписчик» Как удалить фид комментариев из WP 3.1.1? Получать пользовательские значения полей таксономии Создайте запрос, объединяющий список событий с обычным типом сообщений и следуя некоторым требованиям, используя acf Сделать видео-пост перенаправлением на следующий пост после завершения плагин хочет обновить неверный плагин Как выполнить поиск всех пользователей meta из users.php в admin Запустить короткий код с определенным разрешением Заменить различные таблицы стилей, используя условия IE

WordPress конвертирует мой код

У меня возникают трудности с тем, что WordPress постоянно меняет код. IE:

ИЗ ЭТОГО:

<script type="text/javascript" src="<?php echo get_stylesheet_directory_uri(); ?>/js/swfobject.js" ></script> 

TO:

 <script src="&lt;?php echo get_stylesheet_directory_uri(); ?" type="text/javascript">// <![CDATA[ /js/swfobject.js" > // ]]></script> 

И это сводит меня с ума … есть все равно, чтобы отключить это от происходящего? Я хочу, чтобы другие люди редактировали эти страницы, поэтому отключить «GUI EDITOR в профиле пользователей» не похоже на хорошее решение.

Любая помощь приветствуется.

Solutions Collecting From Web of "WordPress конвертирует мой код"

Теги <script> находятся в заголовке документа , а не в теле документа (или, если в теле документа они должны быть последним, перед закрывающим </body> .

Кроме того, если вы добавляете какой- либо код в свой пост, вы столкнетесь с проблемами, если используете редактор Visual, или, что более вероятно, если вы переключаетесь между редакторами Visual и HTML.

Помимо плохой практики добавления тегов сценариев в ваш контент для публикации, вы фактически включаете вызовы PHP, что является ужасающей практикой безопасности.

Есть плагины, которые могут сделать это возможным, но я бы настоятельно рекомендовал против них, и меры по выполнению этой работы почти наверняка испортят эффективность вашей безопасности. Атаки с использованием взлома или взлома вредоносных программ были бы весьма вероятными, и если ваш клиент будет в любом случае технически подкованным, они, скорее всего, потребуют вернуть свои деньги.

Поместите этот вид вызова в header.php или нижний колонтитул, он никогда не должен находиться внутри вашего сообщения.

Я не могу подчеркнуть, насколько велика эта ошибка, и я бы рассматривал такой код как неотложную проблему, независимо от того, насколько она работает или нет, не только с точки зрения безопасности и обслуживания, но и с точки зрения качества и дизайна , Такие вещи всегда возвращаются и кусают вас на задницу с большим количеством работы, чтобы исправить ситуацию.