Intereting Posts
Пользовательская кнопка Tiny MCE для создания настраиваемого всплывающего окна php Как постоянно использовать контент-фильтр? Использование slug страницы в wp_query Массовые регистрации в моем блоге. Отключить определенный домен? Сообщение о статусе Front Post JQuery добавляет функцию Почему пользовательский шаблон не рассматривается как страница с is_page ()? Может ли администратор проверять пароли зарегистрированных пользователей? Пользовательские стили CSS-администратора для стилирования медиа-загрузчика? Как запустить тест WordPressMu для WordPress3? показывать только контейнер со следующими / предыдущими ссылками, если они существуют? Панель инструментов BuddyPress API-интерфейс настраивателя JS: определение active_callback для раздела Пользовательские слайд-шоу типа слайд-шоу для вставки в плагин Автоматическая страница блога с пользовательским дизайном

Как мне отладить ошибку, которую вызывает плагин?

У меня проблема с отладкой, почему плагин, который я создаю, продолжает отображать ошибку. You need to upgrade your database as soon as possible...

Работа, которую я делал до сих пор, была на удаленном веб-сайте, и все, кажется, там работает нормально – без ошибок вообще. Я решил проверить, что произойдет, когда я выброшу плагин в другую среду, чтобы убедиться, что он все равно будет работать нормально. Не забывайте, что обе версии WordPress равны 3.9.1 . Плагин остался прежним, но серверы разные. Единственная другая вещь между ними – это многостраничный сайт (оригинальный сайт-разработчик), а другой – стандартная установка WP.

Первая проблема, которую я разрешил, что было проблемой в том, как я создавал новые таблицы. По какой-то причине replace как имя поля было хорошо на сайте dev, но на vps это не так. Возможно, из-за разных версий MySQL.

Мне было интересно, есть ли способ отладить то, что происходит? Зачем нужна модернизация базы данных?

Solutions Collecting From Web of "Как мне отладить ошибку, которую вызывает плагин?"

Во-первых, вам нужно узнать, какая ваша текущая версия MYSQL …

WordPress требует MySQL 5.0 или более

Начиная с VPS, я предполагаю установку Linux. Просто введите

 mysql -V 

в командной строке, и он вернет вашу версию MYSQL.

Если версия совместима с wordpress, это сообщение может быть сообщением «связанное с плагином / темой». Посмотрите на свои плагины и темы и посмотрите, есть ли у них какие-либо требования к MySQL.